Slowness reported in HighQ ZUS1

Incident Report for Thomson Reuters Legal

Resolved

This incident is currently resolved.
Posted Jan 12, 2026 - 12:52 CST

Update

We are continuing to investigate this issue.
Posted Jan 12, 2026 - 11:07 CST

Investigating

We are currently investigating this issue in US region
Posted Jan 12, 2026 - 11:00 CST
This incident affected: HighQ (USA HiqhQ (Collaborate)).