Email Delivery Delays Affecting Some UK Hosted Customers

Incident Report for Thomson Reuters Legal

Resolved

The issue affecting email delivery to certain recipient domains protected by Mimecast has been resolved. Following an extended monitoring period, we have observed normal email delivery and no further customer impact.

Our investigation found no issues within our platform, and service recovered without any corrective action on our part. Based on the information available, we believe the cause of the disruption was external to our service. We will continue to review any information that becomes available to help further understand the underlying cause.

This incident is now closed. Thank you for your patience while we investigated and monitored the situation.
Posted Jul 17, 2026 - 08:51 CDT

Investigating

We are investigating an issue affecting a limited number of customers where HighQ emails are not being delivered to certain recipient domains using Mimecast. The impact is limited to a small subset of customers. Our teams are actively investigating and will provide further updates as more information becomes available.
Posted Jul 17, 2026 - 05:28 CDT
This incident affected: HighQ (UK HiqhQ (Collaborate)).