Welcome to the Thomson Reuters Legal Product Status page – This is the centralized resource for real-time visibility into the performance and availability of all Thomson Reuters legal products.
This portal provides updates on service status, ongoing incidents, scheduled maintenance, and performance issues across our legal product suite. Our goal is to keep you informed with timely, accurate information so you can plan your work accordingly.
For proactive notifications, subscribe to updates to receive alerts about status changes and incidents affecting your specific legal products.
The slowness reported earlier has been successfully addressed through a SKU upgrade, and the issue is now resolved. Services have stabilized and should now be functioning normally as expected.
Posted Mar 30, 2026 - 07:47 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 30, 2026 - 07:27 CDT
Update
The emergency maintenance has been completed successfully.
Posted Mar 30, 2026 - 07:24 CDT
Update
The maintenance window starts now.
Posted Mar 30, 2026 - 06:33 CDT
Investigating
An emergency maintenance activity has been scheduled in the Azure UK region and is expected to take approximately 30 minutes. During this maintenance window, end users may experience a brief service interruption or temporary outage. We apologize for any inconvenience this may cause and appreciate your patience and understanding. We will share an update once the confirmed start time is available.
Posted Mar 30, 2026 - 05:20 CDT
This incident affected: HighQ (UK HiqhQ (Collaborate)).