Cloudflare DNS global outage

Incident Report for Thomson Reuters Legal

Resolved

Cloudflare have implemented a fix and the incident has now been resolved.
Posted Nov 18, 2025 - 09:00 CST

Investigating

Internal monitoring identified an outage with the third-party service provider. This might be affecting HighQ clients utilizing Cloudflare DNS.

For more information please visit,
https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 07:42 CST
This incident affected: HighQ (EMEA HiqhQ (Collaborate), UK HiqhQ (Collaborate)).