iSheet issue some HIghQ customers hosted in EMEA

Incident Report for Thomson Reuters Legal

Resolved

All services have now been fully restored and are operating normally as of 13:42 UTC.

During this incident, some customers experienced delays and intermittent errors when accessing the platform. We identified the issue within our database infrastructure and applied corrective actions to restore service.

We are continuing to monitor the platform closely to ensure ongoing stability and are conducting a review to help prevent recurrence.

Thank you for your patience while we worked to resolve this.
Posted May 08, 2026 - 09:46 CDT

Investigating

We are currently investigating this issue.
Posted May 08, 2026 - 08:15 CDT
This incident affected: HighQ (EMEA HiqhQ (Collaborate)).