Westlaw Complaint Analyzer down due to an Azure Outage

Incident Report for Thomson Reuters Legal

Resolved

The incident stands mitigated since 00:00 UTC on 30-Oct-25 after Microsoft restored the 'last known good' configuration, followed by performing a cache refresh to restore normal business services. No Further Issues were observed during the monitoring period. Both business and technical validations were conducted successfully.

Probable Cause: A faulty tenant configuration in Azure Front Door caused global service disruption due to a software defect bypassing safety checks. Immediate mitigation included blocking changes and restoring a stable configuration. Recovery was phased to ensure system stability, and enhanced validation and rollback safeguards have been implemented to prevent recurrence.
Posted Oct 31, 2025 - 14:51 CDT

Monitoring

The incident stands mitigated since 00:00 UTC on 30-Oct-25 after Microsoft restored the 'last known good' configuration, followed by performing a cache refresh to restore normal business services. Business and technical validations have been conducted successfully.
The incident will be kept under monitoring until 23:00 UTC on 30-Oct-25. During this time, Microsoft will continue to monitor the situation, along with performing a lessons learned and root cause analysis from the incident.
Posted Oct 29, 2025 - 19:17 CDT

Update

The AFD service is now operating above 98% availability. While the majority of customers and services are mitigated or seeing strong improvement across affected regions, Microsoft is continuing to work on tail-end recovery for remaining impacted customers and services. Microsoft has revised mitigation time and is currently tracking toward full mitigation by 00:40 UTC on 30 October 2025, though we will communicate if mitigation is achieved sooner.
Posted Oct 29, 2025 - 18:57 CDT

Update

The recovery call is in progress.

Our technical teams have evaluated options to reroute traffic away from the impacted Microsoft Azure Front Door (AFD) service. Currently, no immediate or viable workaround is available due to architectural dependencies. We are in regular contact with Microsoft and have requested hourly updates until full recovery is achieved. Microsoft has indicated that recovery is trending towards completion by 23:20 UTC on 29-Oct-25.

We will continue to provide updates as more information becomes available.
Posted Oct 29, 2025 - 16:09 CDT

Update

We are currently experiencing an issue with the Complaint Analyzer functionality feature with our Westlaw service, which is temporarily unavailable. Our team is actively working to resolve this matter as quickly as possible.  We apologize for any inconvenience and appreciate your understanding and patience.  

 Further updates will be provided here as soon as we have more information. If you have any questions, please contact Customer Support.
Posted Oct 29, 2025 - 12:50 CDT

Update

We are continuing to investigate this issue.
Posted Oct 29, 2025 - 12:11 CDT

Investigating

We are currently experiencing an issue with our Westlaw Complaint Analyzer service, which is temporarily unavailable. Our team is actively working to resolve this matter as quickly as possible.  We apologize for any inconvenience and appreciate your understanding and patience.  

 Further updates will be provided here as soon as we have more information. If you have any questions, please contact Customer Support.
Posted Oct 29, 2025 - 12:06 CDT
This incident affected: Contract Express (APAC Contract Express, CAN Contract Express, EMEA Contract Express, OFFSHORE Contract Express, UAE Contract Express, UK Contract Express, USA Contract Express), CoCounsel Core (CoCounsel Core), CoCounsel Drafting (CoCounsel Drafting), Westlaw Canada (Westlaw Canada), Westlaw US (Westlaw US), and Westlaw UK (Westlaw UK).