CLEAR Investigate Search Issue

Incident Report for Thomson Reuters Legal

Resolved

This incident has been resolved.
Posted Aug 29, 2026 - 21:11 CDT

Investigating

We are currently experiencing a technical issue with the CLEAR Investigate Search feature.
Our team is actively working to resolve this as quickly as possible.
We apologize for any inconvenience this may cause and appreciate your patience.
Posted Aug 29, 2026 - 19:17 CDT
This incident affected: CLEAR (CLEAR).