Workflow issue impacting some HighQ customers in UK

Incident Report for Thomson Reuters Legal

Resolved

We have resolved the issue that caused workflows to process more slowly than normal. System resources have been increased and workflow performance has returned to expected levels.

We apologize for any inconvenience.
Posted May 11, 2026 - 08:09 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 11, 2026 - 07:19 CDT

Investigating

We are currently investigating this issue.
Posted May 11, 2026 - 06:28 CDT
This incident affected: HighQ (UK HiqhQ (Collaborate)).